Ir para conteúdo
  • 0

Escolher o email de uma tabela para inserir no destinatário de email do power automate


Guilherme Rodrigues
Ir para solução Solucionado por Frank Figueredo ,

Pergunta

  • Membros

Pessoal bom dia,

Estou com uma duvida de como fazer para dentro do power BI o usuário conseguir escolher para qual email quer que o relatório seja enviado, ao colocar os emails no power automate sempre vem com a ação de apply to each, já tentei colocar como medida =selectedvalue e mesmo assim não funciona, alguem tem uma solução?

Link para o comentário
Compartilhar em outros sites

9 respostass a esta questão

Posts Recomendados

  • 0
  • Membros
  • Solução

@Guilherme Rodrigues Faz assim então:

  • Insere a medida de email selecionado na lista de Campos, caso esteja remove e insere novamente

image.png.1e8bc03f618749410fc845e9d6d20ac5.png

  • Na etapa de Selecionar email vai em Expression e insere e expressão abaixo e  dá ok, onde o que está entre aspas simples é nome da sua medida, exatamente como está escrita em Dax:
  • item()?['Email Selecionado']

    image.thumb.png.0c296861b8c7a9f27a7ba83252992bbe.png

  • Depois fecha tudo, e clica no botão para simular a ação, ai creio que vai dá certo.

 

image.thumb.png.60e79bd608aa529b299e4cd848564991.png

 

OBS: um detalhe é que como o gatilho é um botão clicado do Power Bi, por isso ele pode tá dando erro, então sempre tenta simular clicando no botão quando tiver no PBI Desktop, já se tiver no Portal do Automate, vc consegue simular com o último gatilho já executado.

Testa ai e diz se deu certo

Link para o comentário
Compartilhar em outros sites

  • 0
  • Membros

@Frank Figueredo Bom dia, eu construi a partir desse video, mas nele apenas mostra um email estatico, eu gostaria de ter uma tabela com nome e email e a pessoa selecionar por segmentação de dados o nome dela, assim o email sera enviado pra ela. No caso eu estou usando a medida selectedvalue pra selecionar o email, mas ao implementar no power automate ele aparece como apply to each e acaba não funcionando

Link para o comentário
Compartilhar em outros sites

  • 0
  • Membros

@Guilherme Rodrigues Acabei de fazer um teste com uns dados que tinha aqui e deu certo:

 

O que fiz foi inserir um um slicer com o email do usuario com seleção única, depois capturei isso com uma medida de slectedvalue, depois coloquei a etapa de aplicar a cada, mas como só há um valor, esse só vai aplicar uma vez:

Testa aí e diz se conseguiu.

image.thumb.png.f0262d43f0e1bc91cdfc709fa70c9245.png

 

image.thumb.png.c85f2b312682591c36d91d1e93d64d79.png

 

image.png.9f70c4de5f1788ad829969e118df7c80.png

Link para o comentário
Compartilhar em outros sites

  • 0
  • Membros

@Frank Figueredo valeu pela ajuda, era praticamente o que eu estava fazendo, mas mesmo assim ainda não está funcionando, além de vir 5 emails de uma vez só, as vezes não funciona a automação, fica 16 minutos assim e as vezes pra sempre. Tem mais alguma ideia do que eu possa fazer?

image.png

Link para o comentário
Compartilhar em outros sites

  • 0
  • Membros

Fala @Guilherme Rodrigues demorou mas acho que consegui aqui:

  1. Mantive a medida de Email selecionado
  2. Criar uma operação de Selecionar que a partir da entidade do Power Bi values, pega apenas o Email Selecionado (Medida) image.png.da3450d152d706de6eedca5d1713fb9a.png
  3. Depois usei uma operação de compor que faz um join dos emails que estão selecionados, depois fiz um split e por ultimo pega apenas o primeiro registro, para não enviar vários emails: 
    first(split(join(body('SelecionarEmail'),';'),';'))

    image.png.c53953a868f4f747755d5a4f9320e558.png
  4. Por ultimo foi só usar a saída da operação compor que já está com email único na opção de Para do emailimage.png.c56e07037f6e680473a470fd67171ab4.png

image.thumb.png.b367d8253a7a434725157bff4d3ba5d3.png

Testa ai e diz e diz se deu certo, qualquer coisa é só chamar, e se consegui te ajudar, por gentileza marcar como Melhor Resposta

image.png

 

 

Link que usei de referência: https://tomriha.com/how-to-convert-array-to-a-string-in-power-automate/

Link para o comentário
Compartilhar em outros sites

  • 0
  • Membros

@Frank Figueredo quase deu certo e acho que eu sei o que estou fazendo de errado,

image.png.ef3f472e314c2634792af469531cabe5.png
 

Aqui na parte de map, esta a medida de selectevalue do email, mas esta diferente do seu ja que tem a "tabela do", o que posso fazer para arrumar isso?

Eu testei assim e da esse erro image.thumb.png.9b5d9168b89644a52d63d89ab6fddd88.png

Desde ja muito obrigado pela ajuda

Link para o comentário
Compartilhar em outros sites

  • 0
  • Membros

@Frank Figueredo Cara muito obrigado ajudou muito, e pra ja te deixar ciente, esse icone de "add dynamic content" pra mim não aparecia antes, dependendo da resolução da sua tela ele fica inativo, então vc precisa dar um zoom out para ele não ficar desse jeito

 

Mas cara de verdade me ajudou muito valeuu

image.png

image.png

Link para o comentário
Compartilhar em outros sites

Visitante
Este tópico está impedido de receber novos posts.
×
×
  • Criar Novo...