Ir para conteúdo
  • 0

SEGMENTAÇÃO DE DADOS EM BRANCO


Anderson Souto
Ir para solução Solucionado por Fábio Marquez ,

Pergunta

  • Membros

Boa tarde pessoal,

 

Estou com muitas dificuldades para encontrar o motivo do filtro de segmentação de dados, onde ele aparece a informação "em branco", sendo que ja fiz até o procv no Excel para encontrar onde esta o erro, e não encontrei nenhum.

Os relacionamentos estão corretos, fiz de tudo que estava a minha altura, mas mesmo assim esse erro persiste.

Sei que quando esse filtro esta em branco, significa que na minha tabela fato, tem algum valor que não existe na minha tabela dimensão.

Por gentileza, alguem poderia me explicar outra forma para solucionar esse problema?

Desde ja agradeço.

Muito obrigado.

Em anexo, segue a tabela "Ocorrencias" que seria a fato, e também a tabela "Veiculos grupo Viação Mimo Ltda"

Ocorrencias 1.xlsx Veiculos grupo Viação Mimo Ltda.xlsx Projeto ABM direção segura e econômica Grupo Viação Mimo Ltda.pbix

Link para o comentário
Compartilhar em outros sites

4 respostass a esta questão

Posts Recomendados

  • 0
  • Membros
  • Solução

Bom dia, Anderson.

Veja a linha de raciocínio que pode seguir:

- O filtro que está com o 'Em branco' é do campo Grupo da tabela dVeiculos

- Os relacionamentos nessa tabela são feitos pela coluna placa

- Colocando em uma tabela o campo placa da dimensão e o campo placa das tabelas fato, você identifica quais são as placas sem correspondência na dimensão.

imagem1.PNG.3913f0d71774b0b6c25777aefbb057b4.PNG

Espero ter ajudado.

Abraços.

Link para o comentário
Compartilhar em outros sites

  • 0
  • Membros

Boa noite,

Obrigado pelo suporte, eu sei fazer dessa forma também, mas eu gostaria de descobrir onde esta o erro, tem alguma forma de descobrir isso pelo Power BI?

Por exemplo, saber a informação que tem na minha tabela fato que não esta na minha tabela dimensão.

 

Mesmo assim, muito obrigado.

 

Att,

Link para o comentário
Compartilhar em outros sites

  • 0
  • Membros

@Anderson Souto

 

Eu estava com um caso bastante parecido com o seu (para não dizer igual). Eu tenho uma tabela dimensão (dDistribuidor) com 2 informações principais: "Nome do Cliente" e "Gerente da Conta".

Esta tabela dimensão (dDistribuidor) estava relacionada a duas tabelas fato (fPassivo e fCaptacao), e ambas são geradas por planilha e são relacionadas via NOME DO CLIENTE (atenção aqui! )

A diferença começou a surgir quando tivemos que corrigir a ortografia no nome de um cliente. Só que alteramos apenas na tabela dimensão (dDistribuidor) e em uma das tabelas fato (fPassivo ). 

Nesta tabela fato fPassivo (com o nome do cliente corrigido) fiz todo tipo de checagem para ver se encontrava alguma não-correlação e nada! Continuava com segmentação de dados com opção "em branco".

Foi aí que abri a janela de relacionamentos e lembrei que eu não havia realizado a atualização do nome do cliente na fCaptacao!!! Eu, então, excluí o relacionamento da tabela dimensão com aquela tabela fato (fCaptacao) que eu não tinha alterado o nome. E pronto: não havia mais erro.


Desta forma, fiz as devidas atualizações na tabela fato fCaptação e o erro sumiu. Portanto, @Anderson Souto veja se existe alguma outra tabela fato relacionada a tabela dimensão na qual esta sendo utilizada na segmentação.

 

image.png.32e96082e09bc5c0b5b34b6c073d0ecf.png

Link para o comentário
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar Agora
×
×
  • Criar Novo...