Ir para conteúdo
  • 0

Algo deu errado... Atualização PowerBi online


André Luis o. Napholez

Pergunta

  • Membros

Bom dia pessoal,
Tenho alguns relatórios publicados referente a minha área na empresa e estes pararam de atualizar por este motivo abaixo. Alguém conhece e poderia me ajudar a corrigir, pois, desde que iniciou este problema não consigo utilizar a atualização online.

-----------------------------------------------------------------------------------------------------------

Cluster URIWABI-BRAZIL-SOUTH-redirect.analysis.windows.net

ID da atividadeab63b5a3-f274-4364-b8f5-402258c78c35

Solicitar ID7884e8a5-78ba-3bcb-17b5-3d6652701e97

Hora2022-11-10 12:31:19Z

------------------------------------------------------------------------------------------------------------

Usamos este Banco:

SQL Server

Gateway ta na versão 3000.142.14 (Setembro 2022)

erro bi.JPG

Link para o comentário
Compartilhar em outros sites

5 respostass a esta questão

Posts Recomendados

  • 0
  • Membros

Olá @André Luis o. Napholez!

Também conecto os relatórios a bases em SQL e a única coisa que já aconteceu próximo a isso foi perder a configuração na parte de "Conexão de Gateway" no próprio relatório, sem qualquer razão, nos forçando a reconfigurar essa parte, mas isso ocorreu pouquíssimos casos.

Veja se não tem nenhum erro nessa parte, se a configuração ali tá ok com o Gateway disponível, tenta de repente desativar a configuração e ativar novamente só para forçar um "refresh" na conexão do relatório com o Gateway.

Se mesmo assim não funcionar eu publicaria esse relatório em um workspace teste só para ver se a configuração ficará ok e atualiza sem problemas. Se isso funcionar publica então no workspace de produção, forçando o relatório a atualizar a configuração da parte do Conjunto de Dados.

Desculpe não poder ajudar mais, espero que consiga resolver logo!

  • Obrigado(a) 1
Link para o comentário
Compartilhar em outros sites

  • 0
  • Membros
16 minutos atrás, Michele disse:

Olá @André Luis o. Napholez!

Também conecto os relatórios a bases em SQL e a única coisa que já aconteceu próximo a isso foi perder a configuração na parte de "Conexão de Gateway" no próprio relatório, sem qualquer razão, nos forçando a reconfigurar essa parte, mas isso ocorreu pouquíssimos casos.

Veja se não tem nenhum erro nessa parte, se a configuração ali tá ok com o Gateway disponível, tenta de repente desativar a configuração e ativar novamente só para forçar um "refresh" na conexão do relatório com o Gateway.

Se mesmo assim não funcionar eu publicaria esse relatório em um workspace teste só para ver se a configuração ficará ok e atualiza sem problemas. Se isso funcionar publica então no workspace de produção, forçando o relatório a atualizar a configuração da parte do Conjunto de Dados.

Desculpe não poder ajudar mais, espero que consiga resolver logo!

Bom dia Michele,

Primeiramente agradeço por sua resposta!

"Também conecto os relatórios a bases em SQL e a única coisa que já aconteceu próximo a isso foi perder a configuração na parte de "Conexão de Gateway" no próprio relatório, sem qualquer razão, nos forçando a reconfigurar essa parte, mas isso ocorreu pouquíssimos casos."
R.: Vou tentar fazer desta forma e ver o que acontece de resultado, acho que este ainda não testei. Embora criamos outros gateways também para tentar direcionar para outro local. O que percebi é que a atualização não ocorre por tentar buscar algo dentro do banco de dados, falo porque gerei um relatório somente buscando planilhas do excel e este gera atualização automatica.

_________________________

"Se mesmo assim não funcionar eu publicaria esse relatório em um workspace teste só para ver se a configuração ficará ok e atualiza sem problemas. Se isso funcionar publica então no workspace de produção, forçando o relatório a atualizar a configuração da parte do Conjunto de Dados."

R.: Já fiz este teste e não mudou a situação, inclusive pedi para que outro usuario fizesse o download do pbix. e publicasse em outro workspace que não estivesse relacionado. 

  • Gostei 1
Link para o comentário
Compartilhar em outros sites

  • 0
  • Membros

Olá @André Luis o. Napholez!

Bem estranho mesmo.

Se conseguires, tenta criar um Fluxo de Dados no PBI Online puxando os dados desse banco, com as mesmas tabelas utilizadas no relatório e veja se configura e atualiza sem erros. É uma forma de testar se há mesmo algum problema com banco, mas não deveria ser, se o relatório local carrega os dados normalmente.

Aqui a nossa estrutura é puxar tudo para Fluxos de Dados e daí para os relatórios, desde que eu comecei aqui já fiz essa troca para que não tivesse essa coisa de cada relatório ir no banco de dados sabe, era o dia todo algum relatório indo atualizar, precisando controlar slots de atualização para não concorrer etc., assim eu puxo tudo para os nossos Fluxos principais, temos um mensal e um diário, e depois desses dois principais para os Fluxos das áreas de negócio.

Nossos relatórios puxam desses Fluxos das áreas de negócio e tudo funciona muito bem, pois apenas esses 2 principais, mensal e diário, que puxam dados do banco e com isso praticamente eliminamos os problemas nas atualizações, que antes ocorriam com muita frequência por causa de concorrência, problema no gateway, falta de energia, falta de internet etc. Quando se tem apenas duas atualizações indo no servidor do banco se reduz essa probabilidade de "hora ruim" para atualizar.

  • Obrigado(a) 1
Link para o comentário
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar Agora
×
×
  • Criar Novo...