Ir para conteúdo
  • 0

Configuração de Gateway no Servidor


Francisco Vieira

Pergunta

  • Membros

Olá, Time!

Espero que todos estejam bem!

Preciso de uma ajuda, por favor. Estou tentando fazer a configurarão do Gateway Enterprise em um servidor da empresa, porém, sem sucesso. Quando adiciono a conta, senha e dou o nome do Gateway, fica processando por um bom tempo e me retorna as mensagens em anexo.

Até pensei que fosse por conta da limitação de acesso do meu usuário. Então pedi ajuda ao time de Segurança da empresa, mas me retornaram fazendo alguns questionamentos, por exemplo; se eu teria documentado "quais seriam as URLs que precisavam liberar" e também "se funcionaria via Proxy". Já tentei buscar algumas informações, mas não consegui encontrar nada parecido.

Alguém que conheça afundo o assunto ou que já passou por algo parecido pra dar uma ajuda, por favor?

Deixo aqui meus melhores cumprimentos a todos!

Gateway - Erro na configuração.PNG

Erro configuração gateway.txt

Link para o comentário
Compartilhar em outros sites

5 respostass a esta questão

Posts Recomendados

  • 0
  • Membros

Boa tarde Francisco. 
Vejamos o log de erro enviado:
 

Citar

Failed to update gateway details. You may need to change the account the gateway runs under.
This request operation sent to net.tcp://127.0.0.1:45375/powerbi/gatewayconfiguration/service did not receive a reply within the configured timeout (00:01:00).  The time allotted to this operation may have been a portion of a longer timeout.  This may be because the service is still processing the operation or because the service was unable to send a reply message.

127.0.0.1 é o computador local, neste caso o servidor

45375 é a porta que o gateway tenta acessar para fazer a conexão. 
Ou seja, o gateway tentou acessar seu servidor mas não obteve retorno.



Neste caso, acredito que você não tenha acesso, mas se tiver, o que pode resolver é criar uma regra TCP "na mão" para a porta 45375, conforme abaixo:

1- no menu iniciar digitar "firewall" e abrir

2- no menu lateral esquerdo clicar em "regras de saida"

3- no menu lateral direito clicar em "Nova regra"

4- selecionar opção "porta"

5- protocolo TCP e informar a porta 45375

6- permitir conexão

7- avançar

8- pode nomear a regra para "gateway pbi" ou algo assim.

 

após criar a regra tente fazer novamente a parametrização do gateway.

 

  • Gostei 1
Link para o comentário
Compartilhar em outros sites

  • 0
  • Membros
18 horas atrás, Francisco Vieira disse:

Muito obrigado pela ajuda, Renan. Vou analisar isso agora. Assim que tiver a solução definitiva volto aqui pra deixar registrado!

 

18 horas atrás, renanfelipes disse:

Boa tarde Francisco. 
Vejamos o log de erro enviado:
 

127.0.0.1 é o computador local, neste caso o servidor

45375 é a porta que o gateway tenta acessar para fazer a conexão. 
Ou seja, o gateway tentou acessar seu servidor mas não obteve retorno.



Neste caso, acredito que você não tenha acesso, mas se tiver, o que pode resolver é criar uma regra TCP "na mão" para a porta 45375, conforme abaixo:

1- no menu iniciar digitar "firewall" e abrir

2- no menu lateral esquerdo clicar em "regras de saida"

3- no menu lateral direito clicar em "Nova regra"

4- selecionar opção "porta"

5- protocolo TCP e informar a porta 45375

6- permitir conexão

7- avançar

8- pode nomear a regra para "gateway pbi" ou algo assim.

 

após criar a regra tente fazer novamente a parametrização do gateway.

 

Olá, Renan!

Segui as dicas mencionadas, porém, o erro persiste. 🙁

Obs.: por desencargo, criei uma regra de saída e outra de entrada. Mas sem sucesso.

Link para o comentário
Compartilhar em outros sites

  • 0
  • Membros
1 hora atrás, Francisco Vieira disse:

 

Olá, Renan!

Segui as dicas mencionadas, porém, o erro persiste. 🙁

Obs.: por desencargo, criei uma regra de saída e outra de entrada. Mas sem sucesso.

Fiz algumas pesquisas por aqui, e pelo que vi se deve ao fato do servidor utilizar proxy. 

já existe um tutorial na web para solucionar este caso. Acredito que o mesmo deve funcionar com você.

 

https://joyfulcraftsmen.com/data-engineer-diary-how-to-make-power-bi-gateway-work-in-an-environment-with-a-proxy/

Link para o comentário
Compartilhar em outros sites

  • 0
  • Membros
22 minutos atrás, renanfelipes disse:

Fiz algumas pesquisas por aqui, e pelo que vi se deve ao fato do servidor utilizar proxy. 

já existe um tutorial na web para solucionar este caso. Acredito que o mesmo deve funcionar com você.

 

https://joyfulcraftsmen.com/data-engineer-diary-how-to-make-power-bi-gateway-work-in-an-environment-with-a-proxy/

Obrigado, Renan. Vamos nos falando!

Link para o comentário
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar Agora
×
×
  • Criar Novo...